Studio feature regression

Incident Report for WellSaid Labs

Resolved

The incident has been resolved and Studio functionality is back to normal operation.
Posted Jul 24, 2026 - 21:46 UTC

Identified

The issue has been identified and the team and working on a resolution.
Posted Jul 24, 2026 - 21:13 UTC

Investigating

We are investigating WellSaid Studio showing incorrect functionality to users.
Posted Jul 24, 2026 - 21:11 UTC
This incident affected: Studio (Editor).